桌面平台

Qt Creator is available in binary packages for the following operating systems:

You can use Qt Creator to build, run, debug, and analyze applications on these platforms.

Linux

(K)Ubuntu Linux 18.04 (64-bit) or later is supported.

To build Qt applications using Qt Creator on Linux, you usually need the following:

  • g++
  • make
  • libglib2.0-dev
  • libSM-dev
  • libxrender-dev
  • libfontconfig1-dev
  • libxext-dev
  • libfreetype6-dev
  • libx11-dev
  • libxcursor-dev
  • libxfixes-dev
  • libxft-dev
  • libxi-dev
  • libxrandr-dev
  • libgl-dev and libglu-dev if you use Qt OpenGL (deprecated in Qt 5) or Qt GUI OpenGL functions

macOS

macOS 10.13 or later is supported with the Xcode tools for your macOS version available in the Mac App Store.

Windows

Windows 7 (64-bit) or later is supported.

注意: Some Qt Creator plugins rely on Direct3D (part of DirectX). You might have to manually enable support for it if you are running Windows in a Virtual Machine. For more information, see Hardware 3D acceleration (OpenGL and Direct3D 8/9) and Prepare the Host System to Use DirectX 9 Accelerated Graphics .

Compiling from Source

To build Qt Creator from the source, see the requirements and instructions in the readme file that is located in the source repository.